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Worksheet Editing & Formatting 

Elements of the Excel interface 

 

Tabs Group 

Ribbon 

Quick access toolbar 

Dialog window launcher 

Name box

Row headings Column headings

Formula Bar 

Help 
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Worksheets 

A worksheet is an electronic spreadsheet that is used for entering and storing data in Excel. An 

Excel worksheet contains columns and rows which intersect like a grid to form cells. Excel 

designates columns with alphabetical headers running across the top of the worksheet, and rows 

with numerical headers running down the left of the worksheet. 

Rows & Columns 

How to insert a row: Click on the row number where the row must be inserted, then right click 

and select Insert on the short-cut menu 

How to insert a column: Click on the column heading where the column must be inserted, then 

right click and select Insert on the short-cut menu. 

Rows – Height & Column – Width 

The height of rows can be adjusted by 

selecting the row heading (number) that 

needs adjusting > right click > select Row 

height on the short-cut menu > insert the row 

height 

The width of columns can be adjusted by 

selecting the column heading that needs 

adjusting > right click > select Column 

Width on the short-cut menu > insert the 

column width 

  

Visibility: Hide & Unhide 

Home tab > Cells group > Format > Visibility 

 

Exercise: Hide column C on the Formatting worksheet 
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Rename and/or copy a worksheet 

Right click on Sheet 1 (sheet name) > click on Rename and type in the new name of the 

sheet. Worksheets can be copied and placed in the same workbook or in a new/other existing 

workbook. 

  

Exercise: Rename worksheet S1 to “Formatting” in the Exercise Workbook and change the tab 

colour to red 

Data Validation 

Data Validation is an effective tool in Microsoft Excel when you need to share a spreadsheet 

with other people and want to keep the content unified. In cells with validation enabled, creator 

of the spreadsheet can prompt users to choose data from a list, restrict cells to certain data types, 

or do a few other things that involve complicated custom settings. Basic data validation is easy 

to setup. 

Data Validation is on the Data Tools group on the Data tab 

 

 On the Settings tab, under Allow, select an option: 

 Whole Number - to restrict the cell to accept only whole numbers. 

 Decimal - to restrict the cell to accept only decimal numbers. 

 List - to pick data from the drop-down list. 

 Date - to restrict the cell to accept only date. 

 Time - to restrict the cell to accept only time. 

 Text Length - to restrict the length of the text. 

 Custom – for custom formula. 
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    >     

 Under Data, select a condition: 

 between 

 not between 

 equal to 

 not equal to 

 greater than 

 less than 

 greater than or equal to 

 less than or equal to 

 On the Settings tab, under Allow, select an option: 

 Set the other required values, based on what you chose for Allow and Data. 

For example, if you select between, then select the Minimum: and Maximum: 

values for the cell(s). 

 Select the Ignore blank checkbox if you want to ignore blank spaces. 

 If you want to add a Title and message for your rule, select the Input Message 

tab, and then type a title and input message. 

 Select the Show input message when cell is selected checkbox to display the 

message when the user selects or hovers over the selected cell(s). 

 Select OK. 

Now, if the user tries to enter a value that is not valid, a pop-up appears with the message, “This 

value doesn’t match the data validation restrictions for this cell.” 

Exercise: Open Sheet S7 (2). Use Data validation to select a list for “OK” and “Poor” (Q2:Q3) 

to allow the user to select a comment from a dropdown list for column G (Homework 

comment).  
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Protection and security in Excel 

Excel gives you the ability to protect your work, whether it’s to prevent someone from opening 

a workbook without a password, granting Read-Only access to a workbook, or even just 

protecting a worksheet so you don’t inadvertently delete any formulas. 

Warning:  

 If you forget or lose your password, Microsoft can’t retrieve it for you. 

 You should not assume that just because you protect a workbook or worksheet with a 

password that it is secure - you should always think twice before distributing Excel 

workbooks that could contain sensitive personal information. 

 Worksheet level protection is not intended as a security feature. It simply prevents 

users from modifying locked cells within the worksheet. 

 

Following are the different options available for protecting your Excel 

data: 

 File-level: This refers to the ability to lock down your Excel file by specifying a 

password so that users can’t open or modify it. You have two choices here: 

 File encryption: When you choose this option, you specify a password and 

lock the Excel file. This prevents other users from opening the file.  
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 Setting a password to open or modify a file: You specify a password to open 

or modify a file. Use this option when you need to give Read-only or edit 

access to different users. 

1. Select File > Info. 

2. Select the Protect Workbook box and choose Encrypt with Password. 

3. Enter a password in the Password box, and then select OK. 

4. Confirm the password in the Re-enter Password box, and then select 

OK. 

 

 Mark as Final: Use this option if you want to mark your Excel file as the final 

version and want to prevent any further changes by other users. 

 

 

 Restrict Access: If your organization has permissions set up using Information 

Rights Management (IRM), you can apply any of the available IRM 

permissions to your document. 

 Digital signature: You can add digital signatures to your Excel file.  
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A digital signature is an electronic, encrypted, stamp of authentication on 

digital information such as e-mail messages, macros, or electronic documents. 

A signature confirms that the information originated from the signer and has 

not been altered. 

 Workbook-level: You can lock the structure of your workbook by specifying a 

password. Locking the workbook structure prevents other users from adding, moving, 

deleting, hiding, and renaming worksheets.  

1. Open the Review tab > click on Protect Workbook in the Changes group. 

2. Enter a password in the Password box. 

3. Click OK, and retype the password to confirm it, and then click OK. 

 

 

 Worksheet-level: With sheet protection, you can control how a user can work within 

worksheets. You can specify what exactly a user can do within a sheet, thereby 

making sure that none of the important data in your worksheet are affected. For 

example, you might want a user to only add rows and columns, or only sort and use 

AutoFilter. Once sheet protection is enabled, you can protect other elements such as 

cells, ranges, formulas, and ActiveX or Form controls. 
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Protect a worksheet 

To prevent other users from accidentally or deliberately changing, moving, or deleting data in 

a worksheet, you can lock the cells on your Excel worksheet and then protect the sheet with a 

password. With worksheet protection, you can make only certain parts of the sheet editable and 

users will not be able to modify data in any other region in the sheet. 

Enable worksheet protection 

Worksheet protection is a two-step process: the first step is to unlock cells that others can edit, 

and then you can protect the worksheet with or without a password. 

Step 1: Unlock any cells that needs to be editable 

 In your Excel file, select the worksheet tab that you want to protect. 

 Select the cells that others can edit. 

To lock or unlock cells in Microsoft Excel 2016 and 2013. 

 Select the cells you wish to modify. 

 Open the Home tab > In the Cells area, select Format > Format Cells 

 Select the “Protection” tab. 

 Uncheck the box for “Locked” to unlock the cells. Check the box to lock them. Select 

“OK“. 

 

Step 2: Protect the worksheet 

Next, select the actions that users should be allowed to take on the sheet, such as insert or delete 

columns or rows, edit objects, sort, or use AutoFilter, to name a few. Additionally, you can 

also specify a password to lock your worksheet. A password prevents other people from 

removing the worksheet protection—it needs to be entered to unprotect the sheet. 

 Open the Review tab > click on Protect Sheet in the Changes group 
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 In the Allow all users of this worksheet to list, select the elements you want people to 

be able to change. 

 
 

Option Allows users to 
Select locked 
cells 

Move the pointer to cells for which the Locked box is checked on 
the Protection tab of the Format Cells dialog box. By default, users are allowed 
to select locked cells. 

Select 
unlocked cells 

Move the pointer to cells for which the Locked box is unchecked on 
the Protection tab of the Format Cells dialog box. By default, users can select 
unlocked cells, and they can press the TAB key to move between the unlocked 
cells on a protected worksheet. 

Format cells Change any of the options in the Format Cells or Conditional Formatting dialog 
boxes. If you applied conditional formatting before you protected the 
worksheet, the formatting continues to change when a user enters a value that 
satisfies a different condition. 

Format 
columns 

Use any of the column formatting commands, including changing column width 
or hiding columns (Home tab, Cells group, Format button). 

Format rows Use any of the row formatting commands, including changing row height or 
hiding rows (Home tab, Cells group, Format button). 

Insert columns Insert columns. 
Insert rows Insert rows. 
Insert 
hyperlinks 

Insert new hyperlinks, even in unlocked cells. 

Delete 
columns 

If Delete columns is protected and Insert columns is not protected, a user can 
insert columns but cannot delete them. 

Delete rows If Delete rows is protected and Insert rows is not protected, a user can insert 
rows but cannot delete them. 

Sort Use any commands to sort data (Data tab, Sort & Filter group). Users can't sort 
ranges that contain locked cells on a protected worksheet, regardless of this 
setting. 

Use AutoFilter Use the drop-down arrows to change the filter on ranges when AutoFilters are 
applied. Users cannot apply or remove AutoFilter on a protected worksheet, 
regardless of this setting. 
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Use PivotTable 
reports 

Format, change the layout, refresh, or otherwise modify PivotTable reports, or 
create new reports. 

Edit objects Doing any of the following: 
Make changes to graphic objects including maps, embedded charts, shapes, text 
boxes, and controls that you did not unlock before you protected the worksheet. 
For example, if a worksheet has a button that runs a macro, you can click the 
button to run the macro, but you cannot delete the button. 
Make any changes, such as formatting, to an embedded chart. The chart 
continues to be updated when you change its source data. 
Add or edit comments. 

Edit scenarios View scenarios that you have hidden, making changes to scenarios that you 
have prevented changes to, and deleting these scenarios. Users can change the 
values in the changing cells, if the cells are not protected, and add new 
scenarios. 

 
 Optionally enter a password in the Password to unprotect sheet box and click OK. Re-

enter the password in the Confirm Password dialog box and click OK. 

 

(https://support.office.com/en-us/article/protection-and-security-in-excel-be0b34db-8cb6-

44dd-a673-0b3e3475ac2d) 

Exercise: Unlock the cells A2:E15 & G2:G15 on Sheet7 in the workbook. Then protect the 

worksheet by allowing the user to do everything except to insert and delete columns. 

Hyperlinks 

Hyperlinks automate Excel 2016 worksheets by making the opening of other Office documents 

and Excel workbooks and worksheets just a mouse click away. It doesn’t matter whether these 

documents are located on your hard drive, a server on your LAN (Local Area Network), or web 

pages on the Internet or a company’s intranet. You can also set up e-mail hyperlinks that 

automatically address messages to co-workers with whom you routinely correspond, and you 

can attach Excel workbooks or other types of Office files to these messages.  
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The Hyperlink function is situated on the Links group on the Insert tab. 

 

 

Exercise: Add a hyperlink in cell A1 on worksheet S9 in the Exercise Workbook to worksheet 

S8 cell A1 in the same workbook 

Freeze panes 

By freezing panes, you can keep a particular portion of a worksheet static, while you scroll 

through other areas. You can access the Freeze Panes option from the Freeze Panes drop-down 

list in the Windows group on the View tab. 

  

Exercise: Freeze row 1 on worksheet S2 in the Exercise Workbook 

The Split Command 

When you work with large worksheets, you may need to view different portions of a worksheet 

simultaneously. Using the Split command, you can split the worksheet into multiple resizable 

panes to view its various parts by scrolling through different panes. You can resize these panes 

by dragging the split bars that separate them. 

The Split command is in the Windows group on the View tab. 
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Exercise: Split worksheet S15 in the Exercise workbook and see how it works 

Comments 

Microsoft Excel has the ability of creating comments in each of the cells. Comments enable a 

user to get additional information about the cell such as what the value represents.  

Click on the cell where the comment needs to be inserted > Click on New Comment in the 

Comments group on the Review tab 

 

Exercise: Add comments on worksheet S5 (test info) 

Formatting 

 

Formatting cells 

Home tab > Number group > Format cells dialog window  

When you type something into a cell in a worksheet, Excel makes use of one of the following 

decisions regarding the type of data you entered: 

 You entered a value. 

 You entered a date or time. 

 You entered some text. 

 You entered a formula. [You signal that you’re entering a formula by beginning the 

cell entry with an equal sign (=).] 
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Exercise: Follow the instructions on worksheet S1 

Conditional formatting: Highlight Cells Rules, Data bars & Icon Sets 

Let's imagine you have a worksheet with thousands of rows of data. It would be extremely 

difficult to see patterns and trends just from examining the raw information. Similar to charts 

and sparklines, conditional formatting provides another way to visualize data and make 

worksheets easier to understand. Conditional formatting allows you to automatically apply 

formatting—such as colours, icons, and data bars—to one or more cells based on the cell value. 

Conditional formatting is situated in the Styles group on the Home tab. 

 

 

Exercise:  

Insert Data bars on worksheet S5 for test 1, test 2 and test 3. 

Use the Highlight Cells Rules function to change all marks that is below 50% to red on 

worksheet S5. 
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Go To dialog box 

Use the Go To dialog box when you want to locate specific types of cells in your worksheets. 

The Go To dialog box is in Editing group on the Home tab. 

  

The options available in the Go To Special dialog box. 

Option  What It Selects 

Comments  Only the cells that contain cell comments. 

Constants  All non‐empty cells that don’t contain formulas. This option is useful if you have a 
model  set up and you want  to  clear out all  input  cells  (so you  can enter new 
values), but keep the formulas  intact. Use the check boxes under the Formulas 
option to choose which cells to include. 

Formulas  Cells that contain formulas. Qualify this choice by selecting the check box for the 
type  of  result: Numbers,  Text,  Logicals  (the  logical  values  TRUE  or  FALSE),  or 
Errors. 

Blanks  All empty cells. 

Current  Region A rectangular range of cells around the active cell. This range is determined 
by surrounding blank rows and columns. You can also use the Ctrl+A shortcut key 
combination. 

Current Array  The entire array (used for multicell array formulas). 

Objects  All graphical objects on  the worksheet. This  is useful  if you want  to delete all 
objects. 

Row 
Differences 

If one row is selected, cells that are different from the active cell. If more than one 
row is selected, the same comparison  is done, but the comparison cell for each 
row is the cell in the same column as the active cell. 

Column 
Differences 

If one column is selected, cells that are different from the active cell. If more than 
one column is selected, the same comparison is done, but the comparison cell for 
each column is the cell in the same rows as the active cell. 

Precedents  Cells that are referred to in the formulas in the active cell or selection (limited to 
the active sheet). You can select either direct precedents or precedents at any 
level. 

Dependents  Cells with formulas that refer to the active cell or selection (limited to the active 
sheet). You can select either direct dependents or dependents at any level. 

Last Cell  The lower right cell in the worksheet that contains data or formatting. 
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Option  What It Selects 

Visible  Cells 
Only 

Only visible cells in the selection. This option is useful when dealing with outlines 
or a filtered list. 

Conditional 
Formats 

Cells  that  have  a  conditional  format  applied  (by  using  the 

Home➜Styles➜Conditional Formatting command). 

Data 
Validation 

Cells  that  are  set  up  for  data  entry  validation  (by  using  the  Data➜Data 

Tools➜Data Validation command). The All option selects all cells of this type. The 
Same option selects only the cells that have the same validation rules as the active 
cell. 

(Walkenbach, 2010:21) 

Exercise: Use the Go to function and look for comments on worksheet S5 

Finding and replacing text 

You may want to remove a common leading string, such as a label followed by a colon and 

space, or a suffix, such as a parenthetic phrase at the end of the string that is obsolete or 

unnecessary. You can do this by finding instances of that text and then replacing it with no 

text or other text.  

The Find command thus allows you to locate specific data within a workbook. The Find tab 

of the Find and Replace dialog box contains various options that allow you to perform the 

search. 

You can use wildcard characters, such as an asterisk (*) or a question mark (?), in your 

search criteria: 

 Use the asterisk to find any string of characters. For example, s*d finds "sad" and 

"started". 

 Use the question mark to find any single character. For example, s?t finds "sat" and 

"set". 

You can find asterisks, question marks, and tilde characters (~) in worksheet data by 

preceding them with a tilde character in the Find what box. For example, to find data 

that contains "?", you would type ~? as your search criteria. 

Click Options to further define your search, and then do any of the following: 

 To search for data in a worksheet or in an entire workbook, in the Within box, 

select Sheet or Workbook. 

 To search for data in specific rows or columns, in the Search box, click By Rows 

or By Columns. 
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 To search for data with specific details, in the Look in box, click Formulas, 

Values, or Comments. 

 To search for case-sensitive data, select the Match case check box. 

 To search for cells that contain just the characters that you typed in the Find what 

box, select the Match entire cell contents check box. 

If you want to search for text or numbers that also have specific formatting, click 

Format, and then make your selections in the Find Format dialog box. 

 If you want to find cells that just match a specific format, you can delete any 

criteria in the Find what box, and then select a specific cell format as an 

example. Click the arrow next to Format, click Choose Format From Cell, and 

then click the cell that has the formatting that you want to search for. 

The Replace command allows you to replace existing data in a workbook with new 

data. To replace text or numbers, type the replacement characters in the Replace 

with box (or leave this box blank to replace the characters with nothing), and then 

click Find or Find All. 

The Find & Replace dialog box is in Editing group on the Home tab. 

 
 

Exercise: Replace the surname Smit with Smith in S5 

Find Blank Cells In Excel With A Colour 

In Excel you can have a data set that comes from an external source which is not always 

formatted to your liking. One of the most common things you may encounter are blank cells in 

your Excel data which can hinder your analysis, especially if you are using a Pivot Table to 

analyse the data. 

To find blank cells in Excel you will need to highlight all your data set and bring up the Go To 

Special …> Blanks. 

Then you can fill in the blank cells with a colour and filter by that same colour to drill down to 

these blank cells and take some formatting action. 
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Exercise: Open sheet S15. Stand in A1, press Ctrl & Shift & End together to select the dataset 

and then use Go to Special to find all the blank cells and delete them. 

Automatically Filling a Range with a Series 

Excel has an Autofill feature that can complete a series: 

1. Enter 1 into cell A1. 

2. Enter 2 into cell A2. 

3. Select A1:A2. 

4. Move the mouse cursor to the lower right corner of cell A2 (the cell’s fill handle) and 

when the mouse pointer turns into a black plus sign, drag down the column to fill in 

the cells. 

The data entered in Steps 1 and 2 provide Excel with the information it needs to determine 

which type of series to use. If you entered 3 into cell A2, the series would then consist of odd 

integers: 1, 3, 5, 7, and so on. 

Autofill also works with dates and even a few text items — day names and month names. The 

following table lists a few examples of the types of data that can be Autofilled. 

First Value  Autofilled Values 

Sunday  Monday, Tuesday, Wednesday, and so on 

Quarter‐1  Quarter‐2, Quarter‐3, Quarter‐4, Quarter‐1, and so on 

Jan  Feb, Mar, Apr, and so on 

January  February, March, April, and so on 

Month 1  Month 2, Month 3, Month 4, and so on 

(Walkenbach, 2010:85) 

Enter a series > select the last 2 numbers in the range > right click and copy down to get the 

following options from the mini toolbar: 

 

Exercise: Open worksheet S4 and type 1 in cell A1 and 3 in cell A2. 

Select A1 and A2 and copy a few cells down. Use the Fill series option 

to complete the series. 



18 
 

Paste special 

If you want to paste only a specific aspect of the copied data like its formatting or value, you 

would use one of the Paste Special options. 

Open the Home tab > Clipboard group > Paste > Paste Special. [Or press Ctrl+Alt+V to open 

the Paste Special dialog.] 

 

To pick an option, press the underlined letter for that option. For example, press the letter C to 

pick the Comments option. 

Pick this option  To 
Keyboard 
shortcut 

All  Paste all cell contents and formatting.  Press A 

Formulas  Paste only the formulas as entered in the formula bar.  Press F 

Values  Paste only the values (not the formulas).  Press V 

Formats  Paste only the copied formatting.  Press T 

Comments  Paste only comments attached to the cell.  Press C 

Validation  Paste only the data validation settings from copied cells.  Press N 

All using Source theme  Paste all cell contents and formatting from copied cells.  Press H 

All except borders  Paste all cell contents without borders.  Press X 

Column widths  Paste only column widths from copied cells.  Press W 

Formulas and number 
formats 

Paste only formulas and number formats from copied 
cells. 

Press R 

Values and number 
formats 

Paste only the values (not formulas) and number formats 
from copied cells. 

Press U 
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Mathematical Operation 

Specify which mathematical operation, if any that you want to apply to the copied data. For 

example, put 10 in a cell, press Ctrl+C to copy it. Next, select the cells you want to apply the 

operation to, and go to Home > Clipboard > Paste > Paste Special > select the Operation you 

want, such as Multiplication, and press OK. 

Paste Operation  Action 

None  Specifies that no mathematical operation will be applied to the copied data. 

Add  Adds the copied data to the data in the destination cell or range of cells. 

Subtract  Subtracts the copied data from the data in the destination cell or range of cells. 

Multiply  Multiplies the copied data with the data in the destination cell or range of cells. 

Divide  Divides the copied data by the data in the destination cell or range of cells. 

Other 

Paste Operation  Action 

Skip blanks 
Avoids replacing values in your paste area when blank cells occur in the copy 
area when you select this check box. 

Transpose 
Changes columns of copied data to rows and vice versa when you select this 
check box. 

Paste Link  Links the pasted data on the active worksheet to the copied data. 

Transforming and rearranging columns and rows - Transpose 

Most of the analysis and formatting features in Office Excel assume that the data exists in a 

single, flat two-dimensional table. Sometimes you may want to make the rows become 

columns, and the columns become rows. At other times, data is not even structured in a tabular 

format, and you need a way to transform the data from a nontabular to a tabular format. 

Use the Transpose function to make the rows become columns, and the columns become rows. 

 There is an easy way to convert your rows to columns and vice versa using the 

Transpose feature in Excel.  

 Select the cells containing the headings and data you want to transpose. 

 Click Copy or press Ctrl + C. 

 Click in a blank cell on the worksheet. This cell will be the top, left corner of the 

new table of data. 
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 Click the down arrow on the Paste button and select Paste Special from the drop-

down menu. 

 On the Paste Special dialog box, select the Transpose check box so there is a 

check mark in the box and click OK. 

 The rows become the columns and the columns become the rows. The original set 

of data still exists. You can select those cells and delete the headings and data, if 

desired. 

 

                

Or 
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Exercise: Use the Transpose function to switch the rows and columns on worksheet S10 to 

form a more usable, integrated table. 

[Source: https://support.office.com/en-us/article/paste-special-when-copying-from-excel-

6eafd4c6-388c-4938-a7a9-a76afcd5f5c3 ] 

Spell checking 

You can use a spell checker to not only find misspelled words, but to find values that are not 

used consistently, such as product or company names, by adding those values to a custom 

dictionary. 

Open the Review tab > Proofing group > Spelling 

 

Removing duplicate rows 

Duplicate rows are a common problem when you import data. It is a good idea to filter for 

unique values first to confirm that the results are what you want before you remove duplicate 

values. 

Open the Data tab > Data Tools group > Remove Duplicates 
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In Excel, you have several ways to filter for unique values or remove duplicate values: 

 To filter for unique values, use the Advanced command in the Sort & Filter group on 

the Data tab. 

 To remove duplicate values, use the Remove Duplicates command in the Data Tools 

group on the Data tab. 

 To highlight unique or duplicate values, use the Conditional Formatting command in 

the Style group on the Home tab. 

Exercise: Find the duplicate entry on sheet S3 and remove it (look at Capital). 

Cell & Range Names 

A straightforward way of constructing complex formulas lies in using names instead of cell 

addresses to refer to ranges. 

A range name is a descriptive label assigned to one or more cells for referring to them in a 

formula. The cells may be located anywhere in a workbook; in case of multiple cell ranges, 

they may be adjacent or nonadjacent. When you select a range of cells that have been assigned 

a name, the range name is displayed in the Name Box. A range name must start with a letter, 

cannot contain spaces, and can be up to 255 characters long. 

How to apply Cell and Range Names 

 Select the range you want to name 

 Click in the name box, type a range name of your choice and press Enter 

How to verify that the range is correctly named: 

 Click any cell outside the selected range 

 Click the Name box Drop-down arrow and select the range name 
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Exercise: Add Range names for the Tests 1-3 on worksheet S5. 

Name Manager 

The Name Manager on the Formulas tab can be used to Edit, Delete and/or create new name 
ranges 

 

Exercise: Add a Range name for the Final marks on worksheet S5 using the Name Manager. 

Sort & Filter 

Custom Sort – Sorting on more than one column 

The Custom Sort function is in the Editing group under Sort & Filter on the Home tab 

  

Exercise: Sort the information on worksheet S2 in the Exercise workbook first according to 

Region and then State. 
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Add Subtotals 

Work out the total of several rows of related data by automatically inserting subtotals for the 

selected cells. The Subtotal function is in the Outline group on the Data tab 

 

 
 

 

 

Exercise: Insert Subtotals on S2 in the Exercise workbook 

Make the following selections:  At each change in Region 

Add subtotals to the Population 

Working with tables 

A table is a rectangular range of data that has a row of text headings to describe the contents of 

each column. In Excel, you can arrange data into an ‘official’ table by selecting any cell within 

the data range and click Table in the Tables group on the Insert tab. 

Converting a data range into a table extends functionality, which you can then use to work 

more efficiently and effectively. 
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Reasons why you should consider using a table instead of an ordinary 

data range. 

1. Easy sorting and filtering 

Excel automatically adds filter controls to the header row when you convert a range into a table. 

You do not have to do a thing but use them to sort and filter the table's records. You can execute 

a sort quickly by choosing a criteria item or colour from the drop-down.  

   

If I wanted to see information in red, just filter that colour (but keep in mind that you could just 

as easily also filter by various text values, characters, etc.)  

The totals always adjust to suit the filter/sort. 

    

Exercise: Filter the information on sheet S3 in column B to show only the yellow cells.  
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2. Quick formatting 

Excel automatically applies a banded row format to new tables. If you do not like that format, 

you can choose a new one from 60 predefined formats in the Table Styles gallery on the 

contextual Design tab. You can also use the Format As Table option on the Home tab. As you 

hover over each option, Live Preview updates the actual table. That means less experimentation 

and reformatting. 

 

Exercise: Choose a new format for the table on sheet S2 (Table Style Medium 4) 

3. Effortless data entry 

You can easily extend a table, making data entry much easier. To insert a new record, select 

any cell in the row below the table's last row and enter a value. Excel will automatically extend 

the table's formatting to the new row. It also works with columns. 

 

Exercise: Add a column after to the right of column E and call it Population density. 

4. Automatic nomenclature 

When entering formulas, you use cell references and range names. When working with a table, 

Excel works all that out for you.  
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Excel also extended the table's formatting to the new column. When referring to the table from 

outside the table, Excel will include the table's names in the reference. 

5. No copy necessary 

Excel always anticipates what your next move is going to be. After adding a column and filling 

in the formula for the first line, it automatically fills in the rest of the column so that it totals 

up each row. These columns are called calculated columns. 

 

In the AutoCorrect Options section, click the AutoFormat As You Type tab. 

Check the Fill Formulas In Tables To Create Calculated Columns option. 

The next time you enter a formula into a table, Excel will automatically copy it to the remaining 

cells in the column. 

Exercise: Add a function in the Population density column by dividing the population by the 

area to work out the population density of each capital. 

6. Quick totals 

Add a Totals row to the table as follows: 

Click anywhere inside the table and then click the contextual Design tab. 

Check the Total Row option in the Table Style Options group.  
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This toggling option displays and hides a row of formulas. You can toggle it off for easier data 

entry. Excel does its best to guess your needs by evaluating the actual data. In this case, the 

only total added is a SUM() function. Using that function's drop-down, you can easily change 

the function. Each field has a drop-down from which you can choose or change a function. 

Exercise: Add a total row for the table and use the average function under area and population. 

7. Always visible headers 

In a data range, header cells disappear as you scroll, but table headers are always visible — 

with absolutely no work on your part. Excel replaces the column header cells with the table's 

header row. 

 

8. Formula autofill 

When you extend a table to include a new row, it does not just extend the formatting. The table 

will also copy any formulas. 
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9. Dynamic charts 

If you base a chart on a table, Excel will update the chart automatically as you change and enter 

new data into the table.  

 

 

Exercise: Open sheet S11. Place the data in a table and create a simple column chart. Add a 

new row under Database and call it PowerPoint and fill the cells with fictitious information. 

10. One-click select 

To select a table with a single click, hover the mouse over the top-left corner of the top-left cell 

until the small southeast-pointing arrow shown in Figure M appears. Then, simply click to 

select the entire table. 

 

11. Selecting 

Selecting is easier with tables. If you place your cursor on any cell(s) on the table, right-click, 

place your cursor over Select and you will find yourself three choices. Here you can select the 

column, the row, or the entire table (or click on Ctrl+A). This will be most useful when your 

Excel spreadsheet has a large table. 
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12. Deleting 

If we needed to get rid of an unnecessary row or column, go through the same steps as 

selecting and only this time pick Delete. There you will find that you can delete either the 

column or row. Just remember that the cell(s) that are selected will be the ones affected. 

 

13. Inserting 

Right-click, find Insert and the sub-menu will allow you to insert a row or column either 

above or to the left of the currently selected cell. Another quick way of inserting a new row is 

by selecting the last cell in the last row (before the totals row) and pressing tab. 

 

14. Quick Analysis > Analyse your data instantly 

Quick Analysis provides you the opportunity to insert Formatting, Carts, Totals, Tables and 

Sparklines. 
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Which analysis feature should I use? 

Formatting lets you highlight parts of your data by adding things like data bars and colours. 

This lets you quickly see high and low values, among other things. 

 

Charts Excel recommends different charts, based on the type of data you have selected. If you 

do not see the chart you want, click More Charts. 

 

Totals let you calculate the numbers in columns and rows. For example, Running Total inserts 

a total that grows as you add items to your data. Click the little black arrows on the right and 

left to see additional options. 

 

Tables make it easy to filter and sort your data. If you do not see the table style you want, click 

More. 
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Sparklines are like tiny graphs that you can show alongside your data. They provide a quick 

way to see trends. You can create a Sparkline for a single range and then extend it to multiple 

ranges using the fill handle. Sparklines are also on the Insert tab in the Sparklines group. 

 

 

[Haskins, S. 2013; Mendez-Perez, V; Support.Office] 

Exercise:  

Insert a column on worksheet S5 after Test 3 and add Sparklines that reflect the first 3 test 

scores. 

Use Excel's table nomenclature to quickly create dynamic formulas 

Count the number of sales per person.  

First, you need a table. To create a table, select any cell in a data range. Then, click the Insert 

tab and click Insert in the Tables group.  
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Next, name the table by clicking the contextual Design tab and entering a name into the Table 

Name control in the Properties group. 

 

Use a dynamic COUNTIF() function that counts the number of sales per person. (The formula 

will work the same as it would if you were not referencing a table.) You can put the formula 

most anywhere you like. 

Enter =COUNTIF(  

in cell B2 

After entering the opening parenthesis, enter the name of the table, followed by an opening 

bracket, enter a comma  to separate the range and criteria arguments and then specify the 

criteria argument by pointing to cell B1. Finish it off by entering a closing parenthesis and 

pressing Enter. 

=COUNTIF(Sales,B1) 

      



34 
 

 

[Harkins, S. 2011] 

Exercise: Open S4 on the Excel workbook and use the COUNTIF() function to count the 

number of sales per person. 

Calculate data across worksheets 

Another way of increasing the complexity of your formulas is by using formulas that pull data 

from several worksheets. 

You may find that you have data located in several worksheets. You could cut and paste the 

data into a single worksheet for calculations purposes, but then you run the risk of changing 

the original data. Instead, you can make your calculation span worksheets and not be restricted 

to one. This way, your calculations will be accurate. 

A three-dimensional (3-D) cell reference is a cell reference located in the same place on 

multiple worksheets. It can be used only in a workbook with multiple worksheets. 

 

Exercise: Use Qtr1, Qtr2, Qtr3 and Qtr4 to work out the total for the year on worksheet Sales 

Performance. 
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Referencing in Excel 

Cells are referenced based on the intersection of the respective column and row. For example, 

a cell in column B and row 3 is referenced to as B3. The cell that is selected is called an active 

cell and the reference of the active cell appears in the Name Box of the Formula Bar. 

 

Relative Cell Reference Absolute Cell Reference 

 
 

Relative references – refer to cells by their position in relation to the cells that contains the 

formula. A relative reference to cell A1, for example looks like this: =A1. A relative cell 

reference adjusts to its new location when the formula is copied and pasted. 

Absolute references refer to cells by their fixed position in the worksheet, such as “the cell 

located at the intersection of column and row”. An absolute cell reference does not change, 

even when the formula is copied and pasted elsewhere. An absolute reference is specified with 

two dollar signs; for example: =$A$1. 

Mixed references contain relative and absolute reference, such as “the cell located in column 

A and two rows above this cell”. A mixed reference to cell A1 looks like this: =$A1 or =A$1. 

Dollar sign in a cell reference indicates its “absoluteness”. If the dollar sign precedes only the 

letter, the column coordinate is absolute, and the row is relative. If the dollar sign precedes 

only the number, the column coordinate is relative, and the row is absolute. 

Absolute and mixed references are important when you begin coping formulas from one 

location to another in your worksheet. When you copy and paste, relative references adjust 

automatically, but absolute references do not. (F4 is a shortcut for adding dollar signs) 
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Coping a formula 

 

Exercise: Create your own function on worksheet S5 to work out the average of the students 

marks by adding the marks of tests 1-3 and then divide the answer by 3. Place the answer in 

the Final column. Example: =(Test1+Test2+Test3)/3 

SUM Function 

The SUM function provides a quick way to sum columns or rows of numbers in an Excel 

worksheet. The SUM Function can be found under Auto Sum in the Function Library group 

on the Formulas tab. 

 

SUMPRODUCT 

The SUMPRODUCT function multiplies corresponding components in the given arrays, and 

returns the sum of those products. However, SUMPRODUCT is a much more versatile function 

and it is not limited to the summation of products. 

In this context, an array is a continuous range of cells in a row or column. The number of cells 

must be the same in each array, as in this example of a formula: 

=SUMPRODUCT(B2:B11,C2:C11) 

When applied to the following simple spreadsheet the result of the formula is 770: 
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What SUMPRODUCT has done is this: (1*2)+(2*4)+(3*6)+ … + (10*20) = 770 

The same result is achieved by this version of the formula, in which an asterisk replaces the 

comma:           =SUMPRODUCT(B2:B11*C2:C11) 

It follows that the sign replacing the comma separating the arrays determines the mathematical 

operation that SUMPRODUCT engages between the pairs of values in the two arrays. 

Thus this SUMPRODUCT returns the result 165: 

SUMPRODUCT(B2:B11+C2:C11) ≡ (1+2)+(2+4)+(3+6)+ … + (10+20) 

And this one returns the result 5: 

SUMPRODUCT(B2:B11/C2:C11) ≡ (1÷2)+(2÷4)+(3÷6)+ … + (10÷20) 

The examples above are based on arrays arranged in columns. SUMPRODUCT works 

equally well with arrays of values arranged in rows, as in this example: 

=SUMPRODUCT(A19:F19*A20:F20) 

Exercise: Use the SUMPRODUCT function in worksheet S5 (cells N3:P13) and apply the 

different options as explained under SUMPRODUCT to see the different uses of the function. 

Average Function 

The Average Function returns the average (arithmetic mean) of the arguments. For example, if 

the range A1:A20 contains numbers, the formula =AVERAGE(A1:A20) returns the average 

of those numbers. The Average Function can be found under Auto Sum in the Function Library 

group on the Formulas tab. 

Exercise: Use the Average function and work out the students’ average on worksheet S5 and 

place the answer in the Average column. 
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Median Function 

The Median Function can be found under Auto Sum > More Functions on the Insert Function 

dialog window on the Function Library group on the Formulas tab. 

  

Exercise: Use the Median function and work out the students median on worksheet S5 and 

place the answer in the Median column. 

Date function 

Because there are so many different date formats, and because these formats may be confused 

with numbered part codes or other strings that contain slash marks or hyphens, dates and times 

often need to be converted and reformatted. (See the DATE functions) 

Use Go to Special Constants to find errors in dates: 

If you have a column which contains Dates and you want to check that there are no cells which 

contain Text you can use the Go To dialogue box. (Home tab > Find & Select > Go To 

Special…. > Constants and select the constant that you want to find in your column. In this 

example you only select the Text box, de-select the other boxes, and press OK.  This will 

highlight the cells that contain text and you can begin to format these cells. 

*Useful functions:  

=TODAY() 

The TODAY() function will return the serial number of the current date every time you open 

the workbook/worksheet. The serial number is the date-time code used for date and time 

calculations. [Although this function takes no arguments, you must remember to include the 

empty parentheses.] 

=NOW() 

The NOW() function will return the serial number of the current date and time every time you 

open the workbook/worksheet. This function also takes no arguments. The result of the 

function is a serial date and time value that includes an integer (the date) and a decimal value 

(the time). Excel does not update the value of the NOW continuously. If the value of a cell that 
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contains the NOW function is not current, you can update the value by recalculating the 

worksheet. (You recalculate the worksheet by making a new entry or by pressing F9.) Excel 

also updates the NOW function whenever you open or print he worksheet. 

Useful functions 

 

Exercise: Use the =SUBSTITUTE() function to correct the date on sheet S8 to show 

2017/04/06. 

Remove the previous function and use the =TODAY() function in sheet S8 for column H.  

IF Function 

The IF function checks to see if a condition you specify is true, or false. If true, one thing 

happens; if false, something else happens. The IF function can be found under Logical in the 

Functions Library group on the Formulas tab 
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Exercise: Use the IF Function to determine whom of the students completed their homework 

to a satisfactory level (OK) and if they did, add the 3-points bonus from the HW Bonus table 

to the student’s test average and insert the new marks in the Semester Average column on 

worksheet S7. 

ROUND 

Returns a number rounded to a specified number of decimal places. 

The function ROUND has the following syntax: =ROUND(number, num_digits).  

 

Exercise: Use the ROUND function to round of the marks in the Semester Average column on 

worksheet S7 in the Exercise Workbook. 

Changing the case of text (UPPER, LOWER & PROPER) 

Sometimes text comes in a mixed bag, especially when the case of text is concerned. Using 

one or more of the three Case functions, you can convert text to lowercase letters, such as e-

mail addresses, uppercase letters, such as product codes, or proper case, such as names or book 

titles. 

Unlike Microsoft Word, Microsoft Excel does not have a Change Case button for changing 

capitalization. You can use the UPPER, LOWER, or PROPER functions to automatically 

change the case of existing text to uppercase, lowercase, or proper case. 

=UPPER: Makes all the letters uppercase 

=LOWER: Makes all the letters lowercase 

=PROPER: Makes first letter in each word uppercase 

=PROPER(CONCATENATE(S8!B2,” ”,S8!C2)) 
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Exercise: Use the PROPER function together with the CONCATENATE function to combine 

the First name with the Last name from worksheet S8 into one cell in column C on worksheet 

S9 (in the Full name column), but this time only the first letters must be capitalised. 

Removing spaces and nonprinting characters from text (TRIM) 

Sometimes text values contain leading, trailing, or multiple embedded space characters 

(Unicode character set values 32 and 160), or nonprinting characters (Unicode character set 

values 0 to 31, 127, 129, 141, 143, 144, and 157). These characters can sometimes cause 

unexpected results when you sort, filter, or search. For example, in the external data source, 

users may make typographical errors by inadvertently adding extra space characters, or 

imported text data from external sources may contain nonprinting characters that are embedded 

in the text. Because these characters are not easily noticed, the unexpected results may be 

difficult to understand. To remove these unwanted characters, you can use a combination of 

the TRIM, CLEAN, and SUBSTITUTE functions. 

Remove spaces and nonprinting characters from text 

=TRIM: function removes spaces from text except for single spaces between words. 

=CLEAN: function removes all nonprintable characters from text. 

=TRIM(PROPER()): Removes extra spaces and capitalizes each word of text 

Read more about SUBSTITUTE here: https://support.office.com/en-us/article/Remove-

spaces-and-nonprinting-characters-from-text-023f3a08-3d56-49e4-bf0c-fe5303222c9d 

Exercise: Use the =TRIM(): function to remove extra spaces on sheet S3 in column C. 

Fixing numbers and number signs 

There are two main issues with numbers that may require you to clean the data: the number 

was inadvertently imported as text, and the negative sign needs to be changed to the standard 

for your organization. 

(Convert numbers stored as text to numbers; change numbers into currency or accounting, 

convert a value to text, round numbers to specific decimals .. .see formatting) 
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=TEXT: Converts number or text to new format 

=VALUE(TRIM(CLEAN())): Converts text to number and removes non-printable 

characters 

Exercise: Use FIND and REPLACE to find numbers saved as text and change the format to 

number on sheet S3 column E. 

Merging and splitting columns 

A common task after importing data from an external data source is to either merge two or 

more columns into one, or split one column into two or more columns. For example, you may 

want to split a column that contains a full name into a first and last name. Or, you may want to 

split a column that contains an address field into separate street, city, region, and postal code 

columns. The reverse may also be true. You may want to merge a First and Last Name column 

into a Full Name column, or combine separate address columns into one column. Additional 

common values that may require merging into one column or splitting into multiple columns 

include product codes, file paths, and Internet Protocol (IP) addresses. 

Useful functions: 

CONCATENATE 

The CONCATENATE function combines multiple text strings in a single text string. 

=CONCATENATE(S8!B2,” ”,S8!C2) 

 

Exercise: Use the CONCATENATE function to combine the First name with the Last name 

from worksheet S8 into one cell in column B on worksheet S9 (the Full name column). There 

must be a space between the name and the surname. 

LEFT 

The LEFT function returns the first character(s) in a text based string on the specified number 

of characters.  
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=LEFT(‘S8’!C2,1) 

 

RIGHT 

RIGHT returns the last character or characters in a text string, based on the specific number of 

characters you specify. 

=RIGHT(S8!G2,4) 

 

Exercise: Use the RIGHT function to remove the Extension from the Office Location and 

Extension column on worksheet S8 and place only the extension on worksheet S9 in the 

Extension column. 

MID 

MID returns a specific number of characters from a text string, starting at the position you 

specify, based on the number of characters you specify. 

Syntax 

MID(text, start_num, num_chars) 

 Text Required. The text string containing the characters you want to extract. 
 Start_num Required. The position of the first character you want to extract in text. 

The first character in text has start_num 1, and so on. 
 Num_chars Required. Specifies the number of characters you want MID to return 

from text. 
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CONCATENATE 

=CONCATENATE(LEFT(S8!C2,1),” ”,PROPER(S8!B2)) 

 

Exercise: Use the LEFT function together with the CONCATENATE function to combine the 

initial with the Last name from worksheet S8 into one cell in column D on worksheet S9 (Initial 

& Surname column) 

FIND 

The Find function searches for the specified text and returns the position of the text in another 

text string.   

 

=LEFT(S8!G2,FIND(“-”,S8!G2)-1) 

 

Exercise: Use the FIND function to remove the Location from the Office Location and 

Extension column on worksheet S8 and place only the location on worksheet S9 in the Location 

column (Column G). 

 [More examples: https://support.office.com/en-us/article/Split-text-into-different-

columns-with-functions-49ec57f9-3d5a-44b2-82da-50dded6e4a68]  

Reconciling table data by joining or matching 

Occasionally, database administrators use Office Excel to find and correct matching errors 

when two or more tables are joined. This might involve reconciling two tables from different 

worksheets, for example, to see all records in both tables or to compare tables and find rows 

that do not match. 
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Useful functions: 

VLOOKUP 

The VLOOKUP function is used to find specific information that has been stored in a table of 

data. The VLOOKUP function searches for a value in the leftmost column of a table, and then 

returns a value in the same row from a column that you specify in the table.  

The VLOOKUP function is under Lookup & Reference in the Functions Library group on the 

Formulas tab. 

 

 

 

Exercise: Use the VLOOKUP Function to complete the letter grade for the Semester Average 

of the students with the help of the HW Bonus table and insert the grades in the Grade column 

of worksheet S7. (FIRST complete the IF Function on page 31) 

INDEX() & MATCH 
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VLOOKUP is not the only lookup formula available in Excel, and its numerous limitations 

might prevent you from getting the desired result in many situations. On the other hand, Excel's 

INDEX MATCH is more flexible and has certain features that make it superior to VLOOKUP 

in many respects. 

The INDEX function's syntax and usage 

The Excel INDEX function returns a value in an array based on the row and column numbers 

you specify. The syntax of the INDEX function is straightforward: 

 

Here is a very simple explanation of each parameter: 

 array - this is a range of cells that you want to return a value from. 

 row_num - the row number in array from which you want to return a value. If 
omitted, the column_num is required. 

 column_num - the column number in array from which you want to return a value. If 
omitted, row_num is required. 

If both row_num and column_num parameters are used, the INDEX function returns the value 

in the cell at the intersection of the specified row and column. 

And here is the simplest example of the INDEX formula: 

=INDEX(A1:C10,2,3) 

The formula searches in cells A1 through C10 and returns a value of the cell in the 2nd row 

and the 3rd column, i.e. cell C2. 

When working with real data you would hardly ever know which row and column you want, 

that is why you need the help of the MATCH function. 

The MATCH function's syntax and usage 

The Excel MATCH function searches for a lookup value in a range of cells, and returns the 

relative position of that value in the range. 

For example, if the range B1:B3 contains the values "New-York", "Paris", "London", then the 

formula =MATCH("London",B1:B3,0) returns the number 3, because "London" is the third 

entry in the range. 

The syntax of the MATCH function is as follows: 
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 lookup_value - this is the number or text you are looking for. This can be a value, a 

cell reference or logical value. 

 lookup_array -a range of cells being searched. 

 match_type - this parameter tells the MATCH function whether you want to return an 

exact match or the nearest match: 

 1 or omitted - finds the largest value that is less than or equal to the lookup 

value. The values in the lookup array must be sorted in ascending order, i.e. 

from smallest to largest. 

 0 - finds the first value that is exactly equal to the lookup value. In the INDEX 

/ MATCH combination, you almost always need the exact match, so the third 

argument of your MATCH function is "0". 

 -1 - finds the smallest value that is greater than or equal to lookup_value. The 

values in the lookup array must be sorted in descending order, i.e. from largest 

to smallest. 

How to use INDEX MATCH function in Excel 

Now that you know the basics of these two functions, I believe it has already started making 

sense how Excel's MATCH and INDEX work together. 

The MATCH function determines the relative position of the lookup value in the specified 

range of cells. From there, the INDEX function takes that number, or numbers, and returns a 

value in the corresponding cell. 

 

Example: 
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Find the Unit price of a Product; say Tofu or Chocolade, using the following Index Match 

formula: 

 

Analyse what each component of this formula actually does: 

 The MATCH function searches for the lookup value "Chocolade" in column G, more 

precisely cells $G$2:$G$2156 (Table3[UnitPrice]), and returns the number 26, because 

"Chocolade" is twenty-six in the list. 

 The INDEX functions takes "26" in the second parameter (row_num), which indicates 

which row you want to return a value from, and turns into a simple 

=INDEX($H$2:$H$2156,0). Translated into plain English, the formula reads: search in 

cells H2 through H2156 and return a value of the cell in row 26. 

Here is the result you get in Excel: 
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Why Excel's INDEX MATCH is better than VLOOKUP 

When deciding which formula to use for vertical lookups, the majority of Excel gurus agree 

that INDEX / MATCH is far better than VLOOKUP. However, many Excel users still resort 

to utilizing VLOOKUP because it's a simpler function. This happens because very few people 

fully understand all the benefits of switching from Vlookup to Index Match, and without such 

understanding no one is willing to invest their time to learn a more complex formula. 

4 top benefits of using MATCH INDEX in Excel 

1. Right to left lookup. Excel VLOOKUP cannot look to its left, meaning that your 

lookup value should always reside in the left-most column of the lookup range. With 

INDEX MATCH, your lookup column can be on the right side of your table as well.  

2. Insert or delete columns safely. VLOOKUP formulas get broken or return incorrect 

results when a new column is deleted from or added to a lookup table. With 

VLOOKUP, any inserted or deleted column changes the results returned by your 

formulas because the VLOOKUP function's syntax requires specifying the entire table 

array and a certain number indicating which column you want to pull the data from. 

For example, if you have a table A1:C10 and want to return a value from column B, 

you will put "2" in the third parameter (col_index_num) of a VLOOKUP formula, say 

=VLOOKUP("lookup value", A1:C10, 2). If at a later point, you insert a new column 

between A and B, you will have to change "2" to "3" in your formula, otherwise it 

would return a value from the newly inserted column. 

With INDEX MATCH, you can delete or insert new columns in your lookup table 

without distorting the results since you specify directly the column containing the value 

you want to get. And this is a really great benefit, especially when working with large 
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datasets, since you are able to insert and remove columns without worrying about 

updating every associated vlookup formula. 

3. No limit for a lookup value's size. When using the VLOOKUP function, remember 

that the total length of your lookup criteria should not exceed 255 characters, otherwise 

you will end up having the #VALUE! error. So, if your dataset contains long strings, 

INDEX MATCH is the only working solution. 

Suppose, you are using the following VLOOKUP formula that searches through cells 

B5 to D10 for the value in cell A2: 

=VLOOKUP(A2,B5:D10,3,FALSE) 

The formula won't work if the lookup value in cell A2 exceeds 255 symbols. Instead, 

you shall use the analogous INDEX / MATCH function: 

=INDEX(D5:D10, MATCH(TRUE, INDEX(B5:B10=A2, 0), 0)) 

4. Higher processing speed. If you are working with relatively small tables, the 

difference in Excel's performance will most likely be unnoticeable, especially in recent 

versions. But if you use large worksheets with thousands of rows and thousands of 

lookup formulas, Excel will work much faster if you use MATCH INDEX rather than 

VLOOKUP. Generally, the use of Index / Match formulas increases Excel's 

performance by 13% compared to equivalent Vlookup formulas. 

[Cheasheva, S. 2017: INDEX & MATCH functions in Excel – a better alternative to 

VLOOKUP] 

Exercise: 

Find the Unit price of a Product; say Tofu or Chocolade, using the following Index Match 

formula on S15 in the workbook 

Use the Index and Match formula to complete the letter grade for the Semester Average of the 

students with the help of the HW Bonus table and insert the grades in the Grade column of 

worksheet S7. (First remove the VLOOKUP function) 

[Support.Office: Top ten ways to clean your data] 

Formula Auditing 



51 
 

Excel offers some very effective formula-auditing tools for tracking down a cell that’s causing 

errors by tracing the relationships between the formulas in the cells of your worksheet. 

Formula Auditing is on the Formulas tab 

 

Trace Precedents: 

When you click this button, Excel draws arrows to the cells (the so-called direct precedents) 

that are referred to in the formula inside the selected cell. When you click this button again, 

Excel adds “tracer” arrows that show the cells (the so-called indirect precedents) that are 

referred to in the formulas in the direct precedents. 

Open the Formulas tab > Formula Auditing group 

 

 

Trace Dependents 

When you click this button, Excel draws arrows from the selected cell to the cells (the so-called 

direct dependents) that use, or depend on, the results of the formula in the selected cell. When 

you click this button again, Excel adds tracer arrows identifying the cells (the so-called indirect 

dependents) that refer to formulas found in the direct dependents. 

Remove Arrows: Clicking this button removes all the arrows drawn, no matter what button or 

pull-down command you used to put them there. 
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Show Formulas 

To display all formulas in their cells in the worksheet instead of their calculated values 

 

Error Checking 

When you click this button or click the Error Checking option on its drop-down menu, Excel 

displays the Error Checking dialog box, which describes the nature of the error in the current 

cell, gives you help on it, and enables you to trace its precedents. 

Evaluate Formula 

Clicking this button opens the Evaluate Formula dialog box, where you can have Excel evaluate 

each part of the formula in the current cell. The Evaluate Formula feature can be quite useful 

in formulas that nest many functions within them. 

 

 

Watch Window 
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Clicking this button opens the Watch Window dialog box, which displays the workbook, sheet, 

cell location, range name, current value, and formula in any cells that you add to the watch list. 

To add a cell to the watch list, click the cell in the worksheet, click the Add Watch button in 

the Watch Window dialog box, and then click Add in the Add Watch dialog box that appears. 

Charts 

Chart Type  Explanation 

Column 
Charts 

Column charts are used to compare values across categories 

Line Charts  Line charts are used to display trends over time 

Pie Charts  Pie charts are used to display contribution of each value to a total. 

Bar Charts  Bar charts are used for comparing multiple values 

Area Charts  Area charts are used to emphasize differences between several sets of data over a 
period of time 

XY Scatter 
Charts 

Scatter charts are used to compare pairs of values 

Stock Chart  Data that is arranged in columns or rows in a specific order on a worksheet can be 
plotted in a stock chart. As the name implies, stock charts can show fluctuations in 
stock prices. However, this chart can also show fluctuations in other data, like daily 
rainfall or annual temperatures. Make sure you organize your data in the right order 
to create a stock chart. 

Surface 
Chart 

Data that is arranged in columns or rows on a worksheet can be plotted in a surface 
chart. This chart is useful when you want to find optimum combinations between 
two sets of data. As in a topographic map, colours and patterns indicate areas that 
are  in  the  same  range  of  values.  You  can  create  a  surface  chart  when  both 
categories and data series are numeric values. 

Radar Chart  Data that is arranged in columns or rows on a worksheet can be plotted in a radar 
chart. Radar charts compare the aggregate values of several data series. 

Waterfall 
Chart 

A waterfall chart shows a running total of your financial data as values are added or 
subtracted. It's useful for understanding how an initial value is affected by a series 
of positive and negative values. The columns are colour coded so you can quickly 
tell positive from negative numbers. 

Histogram 
Chart 

Data plotted in a histogram chart shows the frequencies within a distribution. Each 
column of the chart is called a bin, which can be changed to further analyse your 
data. 

Pareto Chart  Using  the  Pareto  chart,  you  can  automatically  sort  the  frequency  of  the most 
prevalent issues (the bar graph) and then show the additive contributions of each 
issue as you move along the horizontal axis (the line graph). 

Funnel Chart  Funnel charts show values across multiple stages in a process. 

Box & 
Whisker 

A box and whisker chart shows distribution of data into quartiles, highlighting the 
mean and outliers. The boxes may have lines extending vertically called “whiskers”. 
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Chart Type  Explanation 

These lines indicate variability outside the upper and lower quartiles, and any point 
outside those lines or whiskers is considered an outlier. Use this chart type when 
there are multiple data sets which relate to each other in some way. 

Treemap  The treemap chart provides a hierarchical view of your data and an easy way to 
compare different  levels of categorization. The treemap chart displays categories 
by colour and proximity and can easily show lots of data which would be difficult 
with other chart types. The treemap chart can be plotted when empty (blank) cells 
exist within the hierarchal structure and treemap charts are good for comparing 
proportions within the hierarchy. 

Sunburst  The sunburst chart is ideal for displaying hierarchical data and can be plotted when 
empty (blank) cells exist within the hierarchal structure. Each level of the hierarchy 
is  represented by one  ring or  circle with  the  innermost  circle as  the  top of  the 
hierarchy. A sunburst chart without any hierarchical data (one level of categories), 
looks similar to a doughnut chart. However, a sunburst chart with multiple levels of 
categories shows how the outer rings relate to the inner rings. The sunburst chart 
is most effective at showing how one ring is broken into its contributing pieces. 

Combo Chart  Data that is arranged in columns and rows can be plotted in a combo chart. Combo 
charts  combine  two or more  chart  types  to make  the data easy  to understand, 
especially when the data is widely varied. Shown with a secondary axis, this chart is 
even easier to read. In this example, we used a column chart to show the number 
of homes sold between  January and  June and  then used a  line chart  to make  it 
easier for readers to quickly identify the average sales price by month. 

[Support.Office: Available charts in Office] 
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Chart suggestions by Dr Andrew Abela (2016) 

[https://extremepresentation.typepad.com/files/choosing-a-good-chart-09.pdf ] 
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Create a Chart 

Select the desired data 

Click on the desired chart gallery on the Insert tab in the Charts group 

 

Creating a Self-Expanding Chart 

A chart will expand automatically when you add new data to a worksheet if the data that you 

use is in a table. 

 

Move Chart to a new sheet 

Select the chart and click on Move Chart in the Locations group on the Design tab 
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Exercise: Move the chart on sheet S11 to a new worksheet and call it Software Sales. 

Select a style and add chart elements for the chart 

 

 

Exercise: Select a style and add chart elements. 

Creating Combination Charts 

Typically, a chart uses a single style: a column chart, a line chart, or a pie chart, for example. 

If your chart has more than one data series, you might want to display multiple styles within 

the same chart — a combination chart. 
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Below is a chart that’s a good candidate for a combination chart. The chart shows average 

temperature and precipitation, by month. But there’s a problem. The two ranges of data vary 

in magnitude, so the precipitation columns are barely visible in the chart. 

The following figure shows the chart after it has been converted it to a combination chart. In 

this chart, the precipitation values are depicted with a line, and it uses a second vertical axis on 

the right. Most would agree that this chart is a vast improvement over the original. 

 

This combination chart displays two data series that vary in magnitude. 

Exercise: Use the table information on worksheet S12. 

Follow these steps: 

Insert a columns chart 

Click on the Precipitation series 

Choose Chart Tools > Design > Type > Change Chart Type. 

In the Change Chart Type dialog box, select Combo chart 

Then select line chart next to precipitation and Secondary Axis 

Adding Moving Averages and other Trendlines 

A Trend line is a graphical representation of trends in a data series that allows you to make 

informed decisions. It can be a moving average, a linear-regression line, or a line generated by 

one of various kinds of nonlinear, curve-fitting methods. 

Add a trendline to a series in an area: Open worksheet S14 and insert a chart (select line chart 

for the example), then click on Trendline under Add Chart Element in the Chart Layout group 

on the Design tab on the Chart Tools tab. Select the Trendline of your choice (Linear for the 
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example). Double click on the Trendline to open the Format Data Series dialog window. On 

the diaglog window you can select the Equation and the R-squared.  

In statistics, the coefficient of determination (R2) indicates how well data points fit a statistical 

model – sometimes simply a line or curve. It is a statistic used in the context of statistical 

models whose main purpose is either the prediction of future outcomes or the testing of 

hypotheses, on the basis of other related information. An R2 of 1 indicates that the regression 

line perfectly fits the data. 

 

 

Exercise: Use the information on worksheet S14 to create a line chart, then add a linear 

trendline that shows the R-squared and the equation on the chart. 
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Pivot tables  

A PivotTable report is an interactive worksheet table that you can use to summarize and analyse 

large amount of worksheet data quickly. It displays the selected worksheet data in a matrix 

format with specialized functionality that enables you to see new data relationships; 

summarize, group, and format selected portions of the data; pivot the data between columns 

and rows; and create concise customised output. 

Steps to consider when creating a pivot chart 

1. You can build a pivot table in about one minute 

Many people have the idea that building a pivot table is complicated and time-consuming, but 

it is simply not true. Compared to the time it would take you to build an equivalent report 

manually, pivot tables are incredibly fast.  If you have well-organized source data, you can 

create a pivot table less than a minute. Here is how: 

 Select any cell in the source data 

 On the Insert tab of the ribbon, click the PivotTable button 

 In the Create PivotTable dialog box, check the data and click OK 

 Drag a "label" field into the Row Labels area (e.g. customer) 

 Drag a numeric field into the Values area (e.g. sales) 

2. Perfect your source data 

To minimize problems down the road, always use good quality source data, organized in a 

tabular layout. "Perfect" source data will have no blank rows or columns, and no subtotals. 

Each column will have a unique name (on one row only), every field will have a value in every 

row, and columns will not hold repeated groups of data (i.e. month names, location names, 

region names, etc.). 

3. Count the data first 

When you first create a pivot table, use it to generate a simple count first to make sure the pivot 

table is processing the data as you expect. To do this, simply add any text field as a Value field. 

You will see a very small pivot table that displays the total record count, that is, the total number 

of rows in your data. If this number makes sense to you, you are good to go. If the number does 
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not make sense to you, it is possible the pivot table is not reading the data correctly or that the 

data has not been defined correctly. 

4. Plan before you build 

Although it is a lot of fun dragging fields around a pivot table, and watching Excel churn out 

yet another unusual representation of the data, you can find yourself going down a lot of 

unproductive rabbit holes very easily. An hour later, it is not so fun anymore. Before you start 

building, jot down what you are trying to measure or understand, and sketch out a few simple 

reports on a notepad. These simple notes will help guide you through the huge number of 

choices you have at your disposal. Keep things simple, and focus on the questions you need to 

answer. 

5. Use a table for your data to create a "dynamic range" 

If you use an Excel Table for the source data of your pivot table, you get a very nice benefit: 

your data range becomes "dynamic". A dynamic range will automatically expand and shrink 

the table as you add or remove data, so will not have to worry that the pivot table is missing 

the latest data. When you use a Table for your pivot table, the pivot table will always be in sync 

with your data. 

To use a Table for your pivot table: 

 Select any cell in the data use the keyboard shortcut Ctrl-T to create a Table 

 Click the Summarize with PivotTable button (TableTools > Design) 

 Build your pivot table normally 

 Profit: data you add to your Table will automatically appear in your Pivot table on 

refresh 

6. Use a pivot table to count things 

By default, a Pivot Table will count any text field. This can be a handy feature in a lot of general 

business situations. For example, suppose you have a list of employees and want to get a count 

by department? To get a breakdown by department, follow these steps: 

 Create a pivot table normally 

 Add the Department as a Row Label 

 Add the employee Name field as a Value 
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 The pivot table will display a count of employee by Department 

7. Show totals as a percentage 

In many pivot tables, you will want to show a percentage rather than a count. For example, 

perhaps you want to show a breakdown of sales by product. But, rather than show the total 

sales for each product, you want to show sales as a percentage of the total sales. Assuming you 

have a field called Sales in your data, just follow these steps: 

 Add Product to the pivot table as a Row Label 

 Add Sales to the pivot table as a Value 

 Right-click the Sales field, and set "Show Values As" to "% of Grand Total" 

8. Use a pivot table to build a list of unique values 

Because pivot tables summarize data, they can be used to find unique values in a field. This is 

a good way to quickly see all the values that appear in a field and also find typos, and other 

inconsistencies. For example, suppose you have sales data and you want to see a list of every 

product that was sold. To create a product list: 

 Create a pivot table normally 

 Add the Product as a Row Label 

 Add any other text field (category, customer, etc) as a Value 

 The pivot table will show a list of all products that appear in the sales data 

9. Create a self-contained pivot table 

When you have created a pivot table from data in the same worksheet, you can remove the data 

if you like and the pivot table will continue to operate normally. This is because a pivot table 

has a pivot cache that contains an exact duplicate of the data used to create the pivot table. 

 Refresh the pivot table to ensure cache is up to date (PivotTable Tools > Refresh) 

 Delete the worksheet that contains the data 

 Use your pivot table normally 

10. Group a pivot table manually 

Although pivot tables automatically group data in many ways, you can also group items 

manually into your own custom groups. For example, assume you have a pivot table that shows 
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a breakdown of employees by department. Suppose you want to further group the Engineering, 

Fulfilment, and Support departments into Group 1, and Sales and Marketing into Group 2. 

Group 1 and Group 2 do not appear in the data, they are your own custom groups. To group 

the pivot table into the ad hoc groups, Group 1 and Group 2: 

 Control-click to select each item in the first group 

 Right-click one of the items and choose Group from the menu 

 Excel creates a new group, "Group1" 

 Select Marketing and Sales in column B, and group as above 

 Excel creates another group, "Group2" 

11. Group numeric data into ranges 

One of the most interesting and powerful features that every pivot table has is the ability to 

group numeric data into ranges or buckets. For example, assume you have a list of voting results 

that includes voter age, and you want to summarize the results by age group: 

 Create your pivot table normally 

 Add Age as a Row Label, Vote as a Column Label, and Name as a Value 

 Right-click any value in the Age field and choose Group 

 Enter 10 as the interval in the "By:" input area 

 When you click OK, you'll see the voting data grouped by age into 10-year 

buckets 

12. Rename fields for better readability 

When you add fields to a pivot table, the pivot table will display the name that appears in the 

source data. Value field names will appear with "Sum of " or "Count of" when they are added 

to a pivot table. For example, you'll see Sum of Sales, Count of Region, and so on. However, 

you can simply overwrite this name with your own. Just select the cell that contains the field 

you want to rename and type a new name. 

13. Add a space to field names when Excel complains 

When you try to rename fields, you might run into a problem if you try to use exactly the same 

field name that appears in the data. For example, suppose you have a field called Sales in your 
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source data. As a value field, it appears as Sum of Sales, but (sensibly) you want it to say Sales. 

However, when you try to use Sales, Excel complains that the field already exists, and throws 

a "PivotTable field name already exists" error message. 

14. Add a field more than once to a pivot table 

There are many situations when it makes sense to add the same field to a pivot table more than 

once. It may seem odd, but you can indeed add the same field to a pivot table more than once. 

For example, suppose you have a pivot table that shows a count of employees by department. 

The count works fine, but you also want to show the count as a percentage of total employees. 

In this case, the simplest solution is to add the same field twice as a Value field: 

 Add a text field to the Value area (e.g. First name, Name, etc.) 

 By default, you'll get a count for text fields 

 Add the same field again to the Value area 

 Right-click the second instance, and change Show Values As to "% of Grand 

Total" 

 Rename both fields as you wish 

15. Automatically format all value fields 

Any time you add a numeric field as a Value in a pivot table, you should set the number format 

directly on the field. You may be tempted to format the values you see in the pivot table 

directly, but this is not a good idea, because it is not reliable as the pivot table changes. Setting 

the format directly on the field will ensure that the field is displayed using the format you want, 

no matter how big or small the pivot table becomes. 

For example, assume a pivot table that shows a breakdown of sales by Region. When you first 

add the Sales field to the pivot table, it will be displayed in General number format, since it's a 

numeric field. To apply the Accounting number format to the field itself: 

 Right-click on the Sales field and select Value Field Settings from the menu 

 Click the Number Format button in the Value field settings dialog that appears 

 Set the format to Accounting and click OK to exit 
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16. Drill down to see (or extract) the data behind any total 

Whenever you see a total displayed in a pivot table, you can easily see and extract the data that 

makes up the total by "drilling down". For example, assume you are looking at a pivot table 

that shows employee count by department. You can see that there are 50 employees in the 

Engineering department, but you want to see the actual names. To see the 50 people that make 

up this number, double-click directly on the number 50 and Excel will add a new sheet to your 

workbook that contains the exact data used to calculate 50 engineers. You can use this same 

approach to see and extract data behind totals wherever you see them in a pivot table. 

17. Clone your pivot tables when you need another view 

Once you have one pivot table set up, you might want to see a different view of the same data. 

You could of course just rearrange your existing pivot table to create the new view. But if 

you're building a report that you plan to use and update on an on-going basis, the easiest thing 

to do is clone an existing pivot table, so that both views of the data are always available. 

There are two easy ways to clone a pivot table. The first way involved duplicating the 

worksheet that holds the pivot table. If you have a pivot table set up in worksheet with a title, 

etc., you can just right click the worksheet tab to copy the worksheet into the same workbook. 

Another way to clone a pivot table is to copy the pivot table, and paste it somewhere else. Using 

these approaches, you can make as many copies as you like. 

When you clone a pivot table this way, both pivot tables share the same pivot cache. This means 

that when you refresh any one of the clones (or the original) all of the related pivot tables will 

be refreshed. 

18. Unclone a pivot table to refresh independently 

After you have cloned a pivot table, you might run into a situation where you really do not 

want the clone to be linked to the same pivot cache as the original. A common example is after 

you have grouped a date field in one pivot table, refresh, and discover that you have also 

accidentally grouped the same date field in another pivot table that you did not intend to change. 

When pivot tables share the same pivot cache, they also share field grouping as well. 

Here is one way to unclone a pivot table, that is, unlink it from the pivot cache it shares with 

other pivot tables in the same worksheet: 

 Cut the entire pivot table to the clipboard 

 Paste the pivot table into a brand new workbook 



66 
 

 Refresh the pivot table 

 Copy it again to the clipboard 

 Paste it back into the original workbook 

 Discard the temporary workbook 

Your pivot table will now use its own pivot cache and will not refresh with the other pivot 

table(s) in the workbook, or share the same field grouping. 

19. Get rid of useless headings 

The default layout for new pivot tables is the Compact layout. This layout will display "Row 

Labels" and "Column Labels" as headings in the pivot table. These are not the most intuitive 

headings, especially for people that do not often use pivot tables. An easy way to get rid of 

these odd headings is to switch the pivot table layout from Compact to Outline or Tabular 

layout. This will cause the pivot table to display the actual field names as headings in the pivot 

table, which is much more sensible. To get rid of these labels altogether, look for a button 

called Field Headers on the Analyse tab of the Pivot Table Tools ribbon. Clicking this button 

will disable headings completely. 

20. Add a little white space around your pivot tables 

This is just a simple design tip. All good designers know that a pleasing design requires a little 

white space. White space just means empty space set aside to give the layout breathing room. 

After you create a pivot table, insert an extra column to the left and an extra row or two at the 

top. This will give your pivot table some breathing room and create a better-looking layout. In 

most cases, I also recommend that you turn off gridlines on the worksheet. The pivot table itself 

will present a strong visual grid, so the gridlines outside the pivot table are unnecessary, and 

will simply create visual noise. 

21. Get rid of row and column grand totals 

By default, pivot tables show totals for both rows and columns, but you can easily disable one 

or both of these totals if you do not want them. On the Pivot Table tab of the ribbon, just click 

the Totals button and choose the options you want. 

22. Format empty cells 

If you have a pivot table that has a lot of blank cells, you can control the character that is 

displayed in each blank cell. By default, empty cells will display nothing at all. To set your 
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own character, right-click inside the pivot table and select Pivot Table options. Then make sure 

that "Empty cells as:" is checked, and enter the character you want to see. Keep in mind that 

this setting respects the applied number format. For example. if you are using the accounting 

number format for a numeric value field, and enter a zero, you'll see a hyphen "-" displayed in 

the pivot table, since that's how zero values are displayed with the Accounting format. 

23. Turn off AutoFit when necessary 

By default, when you refresh a pivot table, the columns that contain data are adjusted 

automatically to best fit the data. Normally, this is a good thing, but it can drive you crazy if 

you have other things on worksheet along with the pivot table, or if you have carefully adjusted 

the column widths manually and do not want them changed. To disable this feature, right-click 

inside the pivot table and choose PivotTable Options. In the first tab of the options (or the 

layout tab on a Mac), uncheck "AutoFit Column Widths on Update". 

[Bruns, D. 2014. 23 things you should know about Excel pivot tables] 

Pivot Table Report 

How to create a PivotTable Report 

Select a cell in the data range you want to use as the source data in the worksheet. > Click on 

PivotTable in the Tables group on the Insert tab.> Specify the data range in the Create 

PivotTable dialog box, choose a new sheet and click OK. 
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The PivotTable Filed List Pane 

The PivotTable Filed List pane is displayed when you select a PivotTable report. The pane 

includes drop zones, wherein you drag and drop fields in order to reorient and rearrange data 

and calculated values in multiple formats quickly. It also includes the Report Filter drop zone 

for fields that need to be eliminated from PivotTable reports. You can make informed decisions 

more efficiently by manipulating the PivotTable report results interactively. 

Choose the fields to add to the PivotTable report 

Check or uncheck the check boxes to select fields for the PivotTable report. 

To use a field in a separate are of the report, from the Choose fields to add to report list box, 

drag the desired fields to the Report Filter, Column Labels, Row Labels, or Values drop zone. 

If desired, check Defer Layout Update if you want to use the Update button to manually updates 

the PivotTable report. 

To move a field to different area, drag the field, or click the field’s drop-down arrow, and make 

the appropriate selection. 
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Exercise: Create a PivotTable: 

Scenario: A Shipping workbook contains a large amount of information about the 

products that were shipped by ABC Ltd in the past several months. Your manager has 

requested a report to review the total quantity of products that Anne sold in January, 

sorted by company name. Since you are confident that your manager might have a similar 

request for information on other salespersons as well, you decide to create a PivotTable 

report to easily extract information without consistently having to rearrange data by 

sorting and re-creating formulas. 

Step 1: Create a PivotTable report of sales by each salesperson and shipped date. 

 Open worksheet S15 in the Exercise Workbook 

 Select PivotTable on the Insert tab in the Tables group 

 In the Create PivotTable dialog box, in the Choose the data that you want to analyse 

section, verify that Select a table or range is selected and in the Tale/Range text box, 

Invoices!$A1:$j$2156 is displayed. In the Choose where you want the PivotTable 

report to be placed section, verify that New Worksheet is selected and click OK to 

create the PivotTable. 
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 In the PivotTable Field List pane, in the Choose fields to add to the report list box, 

check Salesperson, Shipped Date, Product Name, and Quantity to show these items on 

the PivotTable report. 

 

 Observe that Excel automatically determines the most appropriate field from what has 

been checked in the list to place in the Values list box. 

 

 In the PivotTable, observe that the products are displayed in the ascending order of 
the shipped date. 

 

Step 2: Change the label in the PivotTable report to “Total Quantity Sold” by using the 

Values Field Settings dialog box. 
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 In the PivotTable Field List pane, in the Drag fields between areas below section, in 

the Values list box, click SUM of Quantity Drop-down arrow and select Value Field 

Settings. 

 

 In the Value Field Settings dialog box, on the Summarize Values By tab, in the 

Summarize value field by list box, verify that Sum is selected by default and click 

Number Format. 

 In the Format Cells dialog box, in the Category list box, select Number. 

 In the right pane, in the Decimal places spin box, enter 0. 

 Check the Use 1000 Separator (,) check box to separate the value with a comma and 

click OK. 

 

 In the Value Field Settings dialog box, in the Custom Name text box, replace the 

default text with Total Quantity Sold and click OK. 
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 In the PivotTable Field List pane, in the Drag fields between areas below section, 

verify that the Values list box displays the new label as Total Quantity Sold. 

 

Step 3: Create a filter to group the PivotTable by Salesperson and then display products that 

Anne Dodsworth sold. 

 In the PivotTable Field List pane, from the Rows Labels list box, drag the Salesperson 

field to the Report Filter list box. 

 

 On the worksheet, from the Salesperson filter drop-down list, select Anne Dodsworth 

and click OK. 

 

 

Step 4: Display products that Anne sold that were shipped in the month of January. 

 From the Row Labels list box, drag the Shipped Date field to the Report Filter list box 

and place it below Salesperson. 

 

 In the worksheet, in the Shipped Date filter drop-down list, check Select Multiple 

Items. 

 In the Shipped Date Items list check 01-Jan-2011 through 31-Jan-2011 and click OK. 
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 Observe that the PivotReport displays the total quantity of each product sold by Anne 

for the period 01-Jan-2011 to 31-Jan-2011. 

Step 5: In the PivotTable report, display the names of the companies to which the products 

were being shipped. 

 From the Choose fields to add to report list box, drag Company Name to the row 

Labels list box and place it below Product Name. 

 

 Observe that the PivotTable now shows the total quantity of products sold by Anne 

grouped by the company name. 

 

 Close the PivotTable List pane to make more space visible on the worksheet. 

Step 6: Display the subtotals in a separate row at the bottom of each group and format the 

PivotTable report. 

 On the PivotTable Tools Design contextual tab, in the Layout group, from the Sub-

Totals drop-down list, select Show all Subtotals at Bottom of Group. 

 

Filter Data Using Slicers 

A slicer is a filtering tool that allows users to include only the required elements in the 

PivotTables and Pivot Charts. It allows users to add and remove elements from the table display 

so that the data can be compared and evaluated from different perspectives. Users can choose 

more than one Slicer for a PivotTable, if required. 
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The Insert Slicers dialog box allows you to select the fields for slicing PivotTable data. 

This dialog box is on the PivotTabels Tools Analyze tab in the Filter group 

. 

  

 

Exercise: Filtering PivotTable Data using slicers 

Scenario: Your manager has asked you to create a report for a presentation showing the 

sales information of each salesperson. He wants you to display the data for each 

salesperson grouped by country. Though you entered the data in a PivotTable format, you 

want to further filter it so as to keep the presentation as simple as possible. To make the 

presentation simple, you decide to apply Slicers to the PivotTable so that you cans witch 

between different salespersons. 

Step 1: Define Slicers for your table. 

 On the PivotTable Tools Analyze tab, in the Filter group click on Insert Slicer. 

 In the Insert Slicers dialog box, check the Country and Salesperson check boxes and 

click OK. 
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 Observe that two Slicer windows are placed on the worksheet. 

 

 Reposition the Slicer windows to view the entire PivotTable. 

Step 2: View the information related to individual salespersons in a country. 

 In the Country Slicer window, select Brazil to display the information specific to the 

country. 

 Observe that there is no sales data available for the salesperson Anne in Brazil for the 

month of January, indicating that she has not sold anything in Brazil in January. 

 In the Salesperson Slicer window, select Janet to display the information specific to 

the salesperson. 

 Observe that the sales data for the salesperson Janet in Brazil is displayed in the 

PivotTable report. 

PivotCharts 

A PivotChart is an interactive chart that graphically represents the data in a PivotTable report. 

When you create a PivotChart report, a PivotTable report associated with the chart is also 

created. A chart contains standard chart elements, although you can make changes to it by 

changing its type or layout. 

A PivotChart is tied to its PivotTables report’s contents and functionality, not to worksheet 

sells. 

Exercise: Create a PivotChart: 

Scenario: The sales manager at ABC Ltd has asked you to create a column chart based 

on the data on the PivotCharts worksheet to show the sales people how they have been 

doing with their sales for different products in different countries. Instead of creating 

multiple column charts, you decide to present the data in a simple format using a 

PivotChart that can filter the details of sales by country and product. 

Step 1: Create a PivotChart 
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 Open worksheet S15 

 On the Insert tab, in the Charts group, from the PivotChart drop-down list, select 

PivotChart & PivotTable. 

 

 In the Create PivotTable with PivotChart dialog box, in the Choose the data that you 

want to analyse section, verify that Select a table or range is selected and in the 

Table/Range text box, Invoices!$A$1:$J$2156 is displayed. In the Choose where you 

want the PivotTable and PivotChart to be placed, verify that New Worksheet is 

selected and click OK to create the PivotTable. 

 In the PivotTable Field List pane, in the Choose fields to add to the report list box, 

check the Salesperson and Quantity check boxes to display them in the Axis Fields 

(Categories) and Values list box respectively. 

 

 

Step 2: Change the chart title to Salesperson’s Performance 

Step 3: Create a PivotChart report filter to filter the report by country and then by product, to 

display the total quantity for products sold by each salesperson in a country. 

 In the PivotTable Fields List pane, from the Choose fields to add to the report list box, 

drag the Country field to the Report Filter list box. 

 Drag the Product Name field to the Report Filter list box below the Country field. 
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 On the PivotChart, from the Country drop-down list, select Germany and click OK. 

 On the PivotChart from the Product Name drop-down list, select Aniseed Syrup and 

click OK. 

 Verify that both the PivotTable and PivotChart now display the Sum of Quantity for 

the product Aniseed Syrup in Germany for different salespersons. 

 On the PivotChart from the Country drop-down list, select Brazil, and click OK. 

 Observe that there were no sales for the product Aniseed Syrup in Brazil. 

 On the PivotChart from the Product Name drop-down list, select Chang and click OK. 

 Verify that the PivotChart now displays the Sum of Quantity for the product Chang in 

Brazil for different salespersons. 

 

Step 4: Format the PivotChart 

 On the PivotChart Tool Design contextual tab, in the Type group, click Change Chart 

Type. 
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 In the Change Chart Type dialog box, in the right pane, in the column section, in the 

first row, select 3-D Clustered Column and click OK. 

 

 In the Chart Styles group, click the More button. 

 In the displayed gallery, select a style of your choice. 

Power Pivot for Excel 

Microsoft Power Pivot for Excel is an add-in that you can use to perform powerful data analysis 

in Microsoft Excel and bringing self-service business intelligence to your desktop. Using 

Power Pivot for Excel to give your data meaning. By using Power Pivot for Excel, you can 

transform enormous quantities of data with incredible speed into meaningful information to get 

the answers you need in seconds. 

 Take advantage of familiar Excel tools and features 

 Process massive amounts of data in seconds.  

 Import millions of rows of data from multiple data sources. 

 Load even the largest data sets from virtually any source including databases, data 

feeds, Reporting Services, and text files 

 Use powerful new analytical capabilities, such as Data Analysis Expressions (DAX) 

 You can download the full version of PowerPivot software for free.  There is no cost, 

now or in the future. 

  PowerPivot becomes part of Excel and provides powerful, new data analysis 

capabilities. 

With Power Pivot for Excel, you can import millions of rows of data from multiple data sources 

into a single Excel workbook, create relationships between heterogeneous data, create 
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calculated columns and measures using formulas, build PivotTables and PivotCharts, and then 

further analyse the data so that you can make timely business decisions. 

[Power Pivot Add-in. Microsoft Online: https://support.office.com/en-us/article/Power-Pivot-

Add-in-a9c2c6e2-cc49-4976-a7d7-40896795d045] 

So what is this software and why is it free? 

 The software is called "PowerPivot" and is available from Microsoft as a free add-in to Excel. 

Microsoft is making PowerPivot available for free to the hundreds of thousands of Excel users 

because it is counting on a small percentage of them buying additional Microsoft server 

products to publish PowerPivot data models. 

PowerPivot is an innovative adaptation of "Business Intelligence" software used by big 

companies to analyse data.   Microsoft's plan is to "bring Business Intelligence to the masses" 

and PowerPivot is their first step in the plan. Eventually Microsoft can make millions from 

expanded use of its Business Intelligence software. In the meantime you can take advantage of 

free PowerPivot software. 

Almost every organization is drowning in data. Businesses need to analyse marketing data, 

service data and budget data. Schools need to analyse student performance data. Governmental 

agencies need to analyse demographic data. The list goes on and on.  

Most organizations have limited IT resources so they are spending hours and hours of time 

crunching data in Excel.  There is never enough time to fully analyse the data.  

By using PowerPivot you can analyse data in ways that go way beyond "regular Excel".  You 

can get more done in less time. 

 PC World Magazine says it this way: 

“As the name implies, PowerPivot is a PivotTable on steroids. With PowerPivot, 

you can pull into Excel large amounts of data from multiple database tables, 

databases or other sources of data, and sort and filter them almost instantly. Data 

can be reorganized around one column or compared against columns from another 

data source. You can divide the data by time, geographic origin or some other 

parameter. Since it runs Microsoft's business intelligence software on the back end, 

it can do much of what a full-fledged BI application can do.” 
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 Gartner says: 

“Microsoft Excel has been widely used for data aggregation and lightweight 

analysis, but limitations have precluded its use as a high-end ad hoc analysis tool, 

including limits to the data size it can handle and the number of rows it offers, its 

slow calculations, its lack of understanding of dimensional models and its lack of 

centralized spreadsheet management and control. ….. PowerPivot begins to 

address this limitation …... extending interactive analysis capabilities to Excel 

"power users."” 

How the data is stored 

The data that you work on in Excel and in the Power Pivot window is stored in an analytical 

database inside the Excel workbook, and a powerful local engine loads, queries, and updates 

the data in that database. Because the data is in Excel, it is immediately available to 

PivotTables, PivotCharts, Power View, and other features in Excel that you use to aggregate 

and interact with data. All data presentation and interactivity are provided by Excel; and the 

data and Excel presentation objects are contained within the same workbook file. Power Pivot 

supports files up to 2GB in size and enables you to work with up to 4GB of data in memory. 

Steps you use to prepare the dashboard 

Step 1:  Think about the data you want to measure. 

This is the most important step in the process. Whatever you want to improve, start by 

measuring it. An easy to maintain dashboard will help to focus everyone’s attention on 

improvement. 

After deciding what to measure you need to find the data. This might require meeting with a 

technical resource. In this example you got the data from six interconnected database tables 

and two Excel worksheets. 

Step 2: Connect Excel to the data 

PowerPivot has all you need to connect to databases, Excel, Access, text files or sources of 

data from the web. Once connected PowerPivot stores a copy of the data in Excel. Millions of 

rows of data can be effectively stored by PowerPivot using a new technology that compresses 

the data. 
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When you are ready to update the data you just click on the PowerPivot “Refresh” button and 

an updated copy of the data in copied into the PowerPivot database. 

Step 3: Prepare Excel charts to show the measure 

You can make Excel pivot tables and pivot charts from the data in the PowerPivot database. 

Add one pivot table to a worksheet. If you need a pivot chart add the chart to the same 

worksheet. These worksheets will be hidden in the final dashboard. Use them to get your data 

and measures right. 

Step 4: Copy the charts to a single worksheet and add slicers 

Copy charts from the pivot table worksheet to your dashboard sheet. Arrange the charts on the 

dashboard. Then add “Slicers” which are groups of buttons used so filter the data in your charts. 

Each slicer can be attached to multiple pivot tables. When you click on a year in the slicer on 

the dashboard then each of the pivot tables attached to that slicer will show data only for that 

year. In this way slicer buttons on the dashboard worksheet control what data is shown on the 

dashboard charts. 

Excel 2010 has three new features that are all part of the new Excel PowerPivot Self-Service 

BI capability. 

1. Excel PowerPivot allows you to create a simple database within Excel. 

2. Excel PowerPivot pivot table and charts allows you to quickly prepare the charts. 

Unlike the lightweight pivot tables in Excel 2003, these pivot tables can combine 

data from different tables and come with new formulas that are essential for serious 

analysis. 

At first glance PowerPivot pivot tables and pivot charts are similar to the pivot 

table and charts that have been in Excel since 1993. But the new PowerPivot pivot 

table and pivot charts have two very significant differences: 

a. They can combine data from multiple tables. (The old pivot tables required 

you to get all the data in one table.) 

b. The new Data Analysis Expression (DAX) formula language that makes it 

easy to do calculations within the pivot table and line up comparative 

measures like “”Prior Year To Date”. 
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3. Excel Slicers provide a way of selecting data so that multiple charts can be shown 

together and controlled by one set of buttons. 

[Dashboards, PowerPivot, Slicers, and DAX: Things you can do with Excel 2010 

http://www.pivotdashboard.com/Pages/PowerPivotExample.aspx] 

Create relationships in Diagram View in Power Pivot 

Working with multiple tables makes data more interesting and relevant to the PivotTables and 

reports that use that data. When you work with your data using the Power Pivot add-in, you 

can use Diagram View to create and manage the connections among the tables you imported. 

Creating table relationships requires that each table has a column that contains matching values. 

For example, if you are relating Customers and Orders, each Order record would need to have 

a Customer Code or ID that resolves to a single customer. 

1. In the Power Pivot window, click Diagram View. The Data View spreadsheet layout 

changes to a visual diagram layout, and the tables are automatically organized, based 

on their relationships. 

2. Right-click a table diagram, and then click Create Relationship. The Create 

Relationship dialog box opens. 

3. If the table is from a relational database, a column is preselected. If no column is 

preselected, choose one from the table that contains the data that will be used to 

correlate the rows in each table. 

4. For Related Lookup Table, select a table that has at least one column of data that is 

related to the table you just selected for Table. 

5. For Column, select the column that contains the data that is related to Related 

Lookup Column. 

6. Click Create. 

Exercise: Create a very basic PiwerPivot chart 

1. Open PowerPivot example workbook.  

2. Open the Insert tab and Insert the data on sheets1-3 in tables. 

3. Open the PowerPivot tab, click on every table and Add to Data Model 
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4. Click on Diagram view in the Views tab 

 

5. Arrange your tables and draw the relationships between the tables 

 

6. Open the Insert tab and click on PowerView in the PowerView group 

*PowerView is an add in. Open the File tab > Options > Customise Ribbon > Under Choose 

commands, select All commands > Click on the + next to Insert on the Main Tabs group and 
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click on New Group at the bottom of the list > find PowerView under All tabs and move over 

to the Main tabs list. Click on OK.  

 

 

7. Make your selections and draw a few tables. 
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3DMaps 

Microsoft 3D Maps for Excel is a three-dimensional (3-D) data visualization tool that lets you 

look at information in new ways. 3D Maps lets you discover insights you might not see in 

traditional two-dimensional (2-D) tables and charts. 

With 3D Maps, you can plot geographic and temporal data on a 3-D globe or custom map, 

show it over time, and create visual tours you can share with other people. You will want to 

use 3D Maps to: 

 Map data: Plot more than a million rows of data visually on Bing maps in 3-D format 

from an Excel table or Data Model in Excel. 

 Discover insights: Gain new understandings by viewing your data in geographic space 

and seeing time-stamped data change over time. 

 Share stories: Capture screenshots and build cinematic, guided video tours you can 

share broadly, engaging audiences like never before. Or export tours to video and 

share them that way as well. 

You will find the 3D Map button in the Tours group, on the Insert tab of the Excel ribbon, as 

shown in this picture. 

 

Create a Power Map 

When you have Excel data that has geographic properties in table format or in a Data Model—

for example, rows and columns that have names of cities, states, counties, zip codes, 

countries/regions, or longitudes and latitudes—you are ready to get started. Here is how: 

1. In Excel, open a workbook that has the table or Data Model data you want to 

explore in Power Map. 

2. Click any cell in the table. 

3. Click Insert > Map. Clicking Map for the first time automatically enables Power 

Map. 
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Power Map uses Bing to geocode your data based on its geographic properties. 

After a few seconds, the globe will appear next to the first screen of the Layer 

Pane. 

4. 1. In the Layer Pane, verify that fields are mapped correctly and click the drop-

down arrow of any incorrectly mapped fields to match them to the right 

geographic properties.  

For example, make sure that Zip Code is recognized as Zip in the drop-down box. 

 

5. When Power Map plots the data, dots appear on the globe. 

 

6. Click Next to start aggregating and further visualizing your data on the map. 

[Microsoft Office: https://support.office.com/en-us/article/Get-started-with-Power-Map-

88a28df6-8258-40aa-b5cc-577873fb0f4a?ui=en-US&rs=en-

US&ad=US#__exploring_sample_datasets] 
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Explore your data in a Power Map tour 

[3D Maps_Chicago_narcotics.xlsx] 

Microsoft Power Map tour can show a time-based relationship between geographic locations 

and their associated data—such as population numbers, temperature highs or lows, or flight 

arrival delays. 

When you start Power Map from a workbook that does not already contain a tour, a new tour 

with a single scene is automatically created. Tours and scenes are the basic way to save the 

Power Map visualizations of your data. 

You can create as many tours as you want in a workbook. You switch between tours and create 

new tours by using the Launch Power Map box. This example has three tours that show world 

population by continent. 

Create a tour 

 Select any cell in the Excel table or range of cells that has your data. Be sure to do 

this before you create the tour; it makes it easier for you to hook up the data to the 

new tour. 

 Click Insert > Map > Open Power Map. 

The Power Map window appears, showing your new tour. 

 

Create a tour 

 Select any cell in the Excel table or range of cells that has your data. Be sure to do this 

before you create the tour; it makes it easier for you to hook up the data to the new 

tour. 



88 
 

 Click Insert > Map > Open Power Map. 

The Power Map window appears, showing your new tour. 

Add another tour to your workbook 

 Select any cell in the Excel table or range of cells that has your data. Be sure to do this 

before you create the tour; it makes it easier for you to hook up the data to the new 

tour2. Click Insert > Map > Open Power Map. 

The Launch Power Map box appears 

 Click New Tour. 

The new tour appears in the Power Map window. If another tour was already open, Power Map 

closes it. 

Save your tours 

There’s no Save button in Power Map; all tours and scenes are preserved in the state in which 

you close the window. When you save your workbook, any Power Map tours and scenes are 

saved with it. 

All changes you make to a scene in Power Map while editing are saved automatically, but any 

changes you make to a scene in tour playback mode—such as resizing, removing a legend, or 

removing a timeline—aren’t saved. All tours open in edit mode by default, and all the scenes 

in a tour are shown in the Tour Editor pane. 

Add a scene to a tour 

A tour can have a single scene, or multiple scenes that play sequentially to show different views 

of your data, such as highlighting a section of a map, or showing other data related to the 

geographic locations. For example, the first scene in your tour could show population growth 

for cities over time, followed by a scene showing the number of public swimming pools in 

those cities over the same time period, followed by more scenes that show other information 

about those cities. This example shows a four-scene tour for a selection of cities in the U.S. 

Southwest region. 
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Play a tour 

Power Map always plays a tour in full-screen mode. Playback buttons are available at the 

bottom of the screen. 

 

 Open the tour from the Launch Power Map box. 

 In the Power Map window, on the Home tab, click Play Tour. 

You can pause, play, move to the previous or next scene, or go back to edit mode. When you 

pause the tour, you can explore the 3-D environment and interact with it. Any changes you 

make in play mode are not saved as part of the scene. Once you resume playback or go back to 

edit mode, the changes you made in play mode are lost. 
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Delete a tour 

 In the workbook, click Insert > Map > Open Power Map. 

 Right-click the tour, and click Delete. 

Copy a tour 

In the Launch Power Map box, right-click a tour and click Duplicate. This creates a new tour 

that you can fine tune, while leaving the original tour untouched. 

[Microsoft Office: https://support.office.com/en-us/article/Explore-your-data-in-a-Power-

Map-tour-6c5606cf-1e97-43d9-8bb3-c1903987f000] 

Exercise:  

Open S2 and use 3D Maps on the Insert tab to show the population.  

Suggestions: Drag population to height and add region to filter. 

Add Map Labels. 

More examples (S16 & S17) 
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Printing Excel Workbooks 

Headers and Footers 

A header or footer is a data block that compromises text and graphics displayed at the top or 

bottom of a printed page. Excel headers and footers contain 3 placeholders at the left, centre 

and right edges of the page. You can include information in any of the 3 placeholders in the 

header or the footer. Each placeholder can contain text or graphics that will remain the same 

for all the pages or text that changes like page numbers. The Header & Footer function is in 

the Text Group on the Insert tab. 

 

The Header & Footer Tools tab becomes available and on the Design tab in the Header & 

Footer Elements group you have a variety of elements to choose from 

 

Exercise: Insert a header and page numbers for worksheet S5. 

Page Margins 

A page margin is a boundary line that determines the amount of space between the worksheet 

data and the edge of the paper. Excel allows you to select from a list of predefined margins or 

specify custom margins. 

 

Exercise: Change the Page Layout of worksheet S7 to Landscape and set the Page Margins to 

Normal 
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Print Titles Command 

Print Titles can be used to repeat the row(s) and column(s) titles on each page of a worksheet. 

You can set print Titles by using the Print Titles section on the Sheet tab in the Page Setup 

dialog box: 

 

Page Breaks 

Page breaks are lines that split content across pages for print purposes. 

You can insert a Page break by clicking on Breaks in the Page Setup group on the Page Layout 

tab. 

Exercise: Add a page break on S2 after row 40 and repeat the first row by using the Print Titles 

Command and preview your selection. 

Gridlines 

Gridlines are thin lines that divide a worksheet into rows and columns. Printing gridlines 

enables you to read and reference information presented on a printed worksheet easily. 

Gridlines are in the Sheet Options group on the Page Layout tab. 
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Apps 

Apps for Office can help you personalize your documents or speed up the way you access 

information on the web. For example, with an app you could look up items on Wikipedia or 

turn cold data into add cool pictures by using the People Graph without having to leave Excel.  

Apps can be added in the Apps group on the Insert tab. 
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